F6GPK

Remplacement DB9 par USB pour MIXW2.

Recommended Posts

F6GPK

Bonjour à tous et à toutes.

Avant toute chose MEILLEURS VOEUX 2018.

Me remettant à la radio après une absence d'une 10° d'années j'ai voulu réutiliser MIXW2.

La prise DB9 n'existant plus sur les nouveaux ordis je me suis procuré un cordon DB9/USB

Tout ceci fonctionne encore parfaitement bien sur la DB9 d'un vieux ordi sous XP ( plusieurs QSO donc tout va bien).

Par contre, lorsque je passe sur l'ordi récent (WINDOWS10) j'utilise le cordon DB9/USB :

Voici le résultat :

1- En réception tout est parfait.

2- En émission, au niveau logiciel tout va bien. Dans la fenetre du bas ( un CQ par exemple) je vois le message qui se souligne à l'avancée et passe automatiquement dans la fenetre du haut.

3- Le problème c'est que mon TS50 ne passe pas en émission. Rien ne sort. Pas de commande materielle de l'émission.

Ne connaissant strictement rien aux circuits intégrés ( je ne comprends pas de quelle façon est gérée la bascule des datas et de l'émission ) entre DB9 et USB.

Mon interface est comme moi un vieux de la vieille ( il était préconisé pratiquement à la sortie de MIXW2, ça fait quelques années ) mais fonctionne toujours bien.

Si quelqu'un peut me sortir de la "panade" merci d'avance.

PS. : En fichier joint mon nouveau cordon.

Bonne journée à tous.

Paul.

 

 

Capture01.jpg

Partager ce message


Lien à poster
F4DBD

Bonjour Paul,

Le câble que vous utilisez sert à adapter les signaux de l'USB en signaux RS-232C (votre prise 9 broches).

Lorsque vous branchez votre prise 9 broches sur votre ancien PC c'est probablement sur une sortie COM3 ou COM4 que reconnait aussi facilement votre logiciel.

Maintenant avec votre nouveau PC, le port COM n'est pas forcément le même numéro et il faut donc regarder dans le gestionnaire de périphériques quel port COM a été assigné à votre adaptateur USB.

C'est peut-être juste à ce niveau qu'il y a un truc qui coince. Si le logiciel n'envoie pas la commande d'émission sur le bon port COM ça ne fonctionnera pas.

Vous ne précisez pas le nom de votre interface, cela pourrait aider à comprendre comment elle fonctionne et ce qu'elle attend pour basculer en émission.

Il y a principalement 2 familles d'interfaces :

1/ Celle qui fait transiter l'audio in/out au travers d'une isolation galvanique entre le TX et le PC + qui utilise le port RS-232C pour la commutation en émission (et/ou le CAT)

2/ celle qui possède une carte audio propre et qui gère par le port USB à la fois le son mais aussi la commutation en émission + le CAT

Je pense que vous avez le type 1 et donc c'est juste par le port RS-232C que la commutation se fait. Logiquement vous devriez pouvoir tester la bascule de votre poste en émission via le VOX du TX. Lorsque le logiciel envoie la modulation, le poste va passer en émission.

Si c'est bien le cas c'est donc bien que le problème se situe au niveau de la commutation via la prise DB9 (la commande DTR ou CTS n'est pas reçue).

Partager ce message


Lien à poster
F6GPK

Bonjour Frédérick,

Merci déja de bien vouloir perdre un peu de temps à essayer de m'aider.

Dans l'ordre j'ai été voir dans GESTION DES PERIPHERIQUES : Port com et ltp attribué (Port 13) sous le nom : PROLIFIC USB to SERIAL Com Port ( COM 13).  ( Propriété : Le port fonctionne correctement  ).

J'ai paramétré dans MIXW2 ce numéro de port c'est à dire ( PORT 13)  Anciennement port3.

Pour le vox ( solution qui m'aurait suffit ) pas de "bol" car sur le TS50 il n'y a pas de VOX.

Par contre vous me dites que le problème peut se situer au niveau des commutations DB9 (DTR/CTS). Mon branchement direct DB9 sur l'ancien ORDI ( DB9 présente) fonctionne correctement.

J'ai vu sur Internet qu'il existe des cables d'adaptation croisé. Fraudrait-il que je rajoute encore  la sortie de mon interface et mon nouveau cable (DB9/USB) ce genre de bride.

Je suis "perdu" pour de bon.

75 berges dans 3 mois, les neurons commence à se dilués.

Je suis de l'époque des lampes et du début des transistors en émission ! ! ! ! ! ! ! ! ! !

De l'eau est passée sous les ponts  . . . . 

PS : Schéma de mon périph. joint.

Bon soirée.

Paul.

interface MIXW2.jpg

Partager ce message


Lien à poster
F4DBD

Merci pour ces précisions qui aident un peu plus.

Lorsque je parle d'un problème de commutation je veux dire un problème de cheminement du signal RTS de votre PC qui arrive sur la commande PTT de votre poste au travers de l'interface USB. 

Regardez la page 6 de ce document :

http://k6ix.net/MixW/MixWManual.pdf

Je suppose que c'est comme cela que vous avez indiqué le port COM à MixW ?

Avec un Voltmètre vous pouvez déjà regarder si votre broche RTS (entre la masse et la broche 7) en sortie d'adaptateur USB/RS232 (côté DB9) change bien d'état lorsque le logiciel passe en émission. Si c'est le cas c'est peut-être l'adaptation du 2N2222 n'est plus bonne avec la tension que délivre l'adaptateur...

Un câble croisé n'est pas utile dans votre cas. Il sert pour les données échangées entre 2 ordinateurs (on envoie le TX dans le RX et vice-versa). Dans votre cas vous n'utilisez qu'une bascule d'une commande RTS (pour la mettre à l'état haut ou bas).

Partager ce message


Lien à poster
F6GPK

Re-bonsoir,

Je vais vérifier mon paramétrage MIXW2  et effectuer au voltmètre le controle de mon adaptateur.

OK pour le cable croisé je n'en connaisais pas l'utilisation.

Bonne soirée.

PS : je reviendrai sur le forum pour vous donner les résultats de mes mesures.

Paul

Partager ce message


Lien à poster
F6GPK

Bonjour à tous et de même pour F4DBD,

Le coup de main commence à porter ses fruits.

Pour le paramétrage de MIXW2 c'est OK, j'avais utilisé la même page (6) .

Pour la vérification des broche ( Masse 5 ) et RST (7) ce n'est pas encore fait. Par contre j'ai ouvert ma DB9 ( femelle) sortant de mon interface et refais les soudures.

Bien m'en a pris car maintenant mon TS50 passe bien en émission ( ON AIR ) s'allume, la réception est bien sûr coupée.

Le logiciel traite donc bien ça, dans la fenêtre du bas le message se souligne et passe à proportion dans la fenetre du haut.

Malheureusement toujours pas de HF sur le TOS/METRE. :(

Je suppose que mon signal de sortie n'est pas traité ( je dis peut-être une bêtise ).

Ne comprenant pas ce que fait le circuit intégré qui est dans cette nouvelle prise DB9/USB je suis "pommé".

Si j'avais dès le début essayé de m'interesser à ces "bébêtes" je n'en serai pas là :huh:

Trêve de baratin, bonne journée à tous.

Paul.

 

 

Partager ce message


Lien à poster
F8EBL

Bonjour.

Ca va marcher !

il y a 55 minutes, F6GPK a dit :

ce que fait le circuit intégré qui est dans cette nouvelle prise DB9/USB

C' est juste une adaptation de niveaux.

En fait, votre câble convertit un signal TTL en sortie du chip usb en signal rs232 ( +/-15v) .

Et votre interface adapte à nouveau les niveaux de signal à la commutation du PTT (mise à la masse d' une tension, 6, 8 ,12 volts).

Selon votre schéma, la commutation des deux lignes audio, de et vers votre transceiver se fait directement via des relais .

Donc vous ne disposez pas d' une isolation galvanique entre les circuits de votre émetteur et de votre PC.

Ceci peut engendrer des boucles de masse, des bruits parasites en quantité et de manière imprévisible.

Perso, je me débrouille avec des transfos 600 / 600 ohms genre ligne ptt et un potard pour régler le niveau, surtout dans le sens PC>trx, potard coté trx.

Maintenant, je vous conseille de voir déjà e que vous pouvez avoir en réception avant d' envisager l' émission.

Je ne connais pas bien Mixw, mais si votre câblage est bon, vous devriez avoir quelque chose en réception sur Mixw.

Est ce le cas ?

J' ai peut être loupé quelque chose mais je n' ai pas vu quelle interface vous utilisez ( commere, home made )??

cordalement,

f8ebl

 

Partager ce message


Lien à poster
F4DBD

Bonjour Paul,

Déjà un problème de réglé  : le passage en émission

Maintenant pour l'absence de modulation émise via le poste, cela veut peut-être dire que vous n'avez pas bien sélectionné le périphérique audio de votre PC dans le logiciel MixW ou bien que le niveau de sortie a été réglé trop faiblement.

Regardez dans le menu Configure/Sound Device Setting de MixW2 si tout est bien réglé.

Cette page peut vous apporter un peu d'aide je pense :

http://14ww210.blogspot.fr/2013/04/mixw2.html

Une chose à savoir, comme l'a expliqué F8EBL, votre câble USB/RS232C ne traite pas d'audio. Il ne fait que gérer la commutation PTT. Donc maintenant que la commutation en émission fonctionne, ne vous en occupez plus.

C'est vos câbles branchés sur la sortie HP et sur l'entrée micro de votre PC qui se chargent d'apporter du signale de modulation à votre transceiver. C'est donc du côté de la carte son de votre PC qu'il faut regarder...

 

Partager ce message


Lien à poster
F6GPK

Bonjour F8EBL,et comme on dit 73 QRO

Pour résumer:

Prénom de l'opérateur Paul, licence F1 en 77 et F6 en 80 et l'OM a 75 berges au compteur.

Voici 10 ans que j'avais pratiquement abandonné le trafic en raison de multiples problèmes de santé ( le moral n'étant plus là ).

Je m'y suis un peu remis.

Pas grand chose comme station : un ALINCO DR150 en VHF/UHF  ( trafic pratiquement inexistant actuellement dans le midi ).

                                                 un TS50 de KENWOOD pour le DECA sur Doublet raccourci tri-bande en V inversé.  ( pas de VOX sur le TS50 , je dis ça pour la suite).

                                                 interface de fabrication OM  datant de la sortie de MIXW2   ( je pense autour des années 90 ).

                                                 schéma en fichier joint.

Cet interface fonctionne encore parfaitement sur mon vieux ordi ( grand tour, un monstre en taille ) sous WINDOWS XP mais qui avait l'avantage de disposer d'une prise DB9.

Voulant refaire tourner tout ça sous WINDOWS 10, j'ai acheté un cordon USB/DB9  ( si plusieurs fichiers joints sont acceptés je joint la photo ).

Voici mon problème :

Jusqu'à ce matin, j'avais une réception ( par ex. bpsk ) parfaite, mon logiciel faisait son travail, mais le tranceiver ne passait pas en émission.

A tout hasard j'ai refais les soudures dans la DB9 (femelle), sortie de mon interface.

Certainement mauvaise soudure ou soudure froide, mais "miracle" maintenant mon tranceiver passe en émission ( ON AIR ) allumé.

Mais pas plus avancé car pas de hf en sortie ( ça ne vient pas du tranceiver car en passant en CW en faisant un tune l'aiguille du TOSMETRE passe au "taqué" ).

Là, je suis pommé car comme je le disais à F4DBD, je n'ai jamais touché aux circuits intégrés.

Je suis de la génération des premiers transistors en EMISSION . . . . ça date pas d'aujourd'hui   HI ! ! ! ! !

Voila pourquoi j'appelle au secours des OM plus techniciens que moi.

Bonne soirée.

Paul.

 

 

interface MIXW2.jpg

Partager ce message


Lien à poster
F8EBL
Il y a 2 heures, F6GPK a dit :

en passant en CW en faisant un tune

Avec l' interface vous pouvez donc commuter le PTT et le keyer du transceiver? Ou c' est en commandant le tune depuis le transceiver ?

Parce que si vous pouvez commander l" émission en cw, c' est que tout marche, sauf la bf vers le trx.

L' idée qui me vient, c' est qu' en général, on se sert à la fois du signal dtr ET cts ( ou rts, je sais plus ) pour commander le passage en émission, le dtr (pin 4 db9 ) commute le PTT et le rts

ou cts ( pin 7, 8 ) commande le keyer (ou lycée de Versailles ).

Vous pouvez sans doute assigner manuellement les dtr et rts à  l' une ou à l' autre des fonctions ptt ou keyer dans le menu de configuration de mixwave

Visiblement, c' est la pin de rts qui est câblée sur votre interface, regardez si c' est bien celle là qui est sélectionnée dans le menu config de Mixw.

Je ne connais pas ce logiciel, un autre lecteur pourra vous guider mieux que moi.

Je me permets d' insister lourdement sur la nécessité d' une isolation galvanique entre PC et station, pour les problèmes de parasites mais surtout d' isolation du point de vue de la HF.

C' est pas parce que ça a marché une fois, dans le temps, que ça marchera tout le temps, a fortiori avec des matériels et des configurations différentes.

Et la réparation d' une platine bf sur un transceiver est plus difficile que de câbler une interface adaptée.

http://f4esk.blogspot.fr/2011/07/interface-simple-pour-modes-numeriques.html

Un exemple.

Le ts117 peut être remplacé par un deuxième optocoupleur .

 

Partager ce message


Lien à poster
F6GPK

Bonjour à tous,

Concernant la liaison DB9/USB, message en particulier à F8EBL et F4DBD.

Encore merci pour vos précieux renseignements et avis.

Actuellement tout fonctionne. J'ai d'abord récupéré le passage en émission et après avoir réglé sur l'ordi le niveau sur les entrée et sortie (HP et MICRO ) maintenant tout fonctionne.

Pour F8EBL, je vais suivre vos conseils et à temps perdu fabriquer une nouvelle interface plus sécurisante que la mienne. ( genre de celle proposée à l'adresse internet que vous m'avez indiqué).

Encore merci à tous les deux pour vos conseils éclairés.

Bonne soirée.

Paul.

 

 

Partager ce message


Lien à poster
F4DBD

Bonjour Paul,

Parfait ! Amusez-vous bien sur l'air et au plaisir de faire le QSO entre nos deux stations.

73, Frédérick

Partager ce message


Lien à poster

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant